Как заблокировать обновление одного из пакетов, или используем YUM VERSIONLOCK CENTOS

Если вам необходимо не обновлять какой то из пакетов, можно использовать пакет yum-versionlock, устанавливаем:
# yum -y install yum-versionlock
или
# yum -y install yum-plugin-versionlock
Послу установки пакета можно использовать следующие команды для работы:
yum versionlock package-name-here
yum versionlock package1 package2
yum versionlock add package-wildcard
yum versionlock add package1*
yum versionlock [command] package1*

например, для блокировки пакета nginx:
# yum versionlock nginx
или
# yum versionlock add nginx
Для просмотра заблокированных пакетов:
# yum versionlock list
Для изменения списка пакетов, удаления пакета из списка:
# yum versionlock delete nginx
Очистка всего пакета:
# yum versionlock clear

 

EnglishRussian